1. 系统介绍 - TestCenterEnterprise帮助文档

1. 系统介绍

TestCenter Enterprise（简称TCE）是由上海泽众软件科技有限公司开发的一款面向测试流程的测试项目管理工具，可迅速建立完善的测试体系，规范测试流程，提高测试效率与质量，实现对测试的过程管理。

告别安装时代，轻松管理测试项目

随着互联网的快速发展，轻量级的TestCenter上线了。它免去繁琐的安装部署步骤，更加注重敏捷测试项目管理。它集测试项目管理、缺陷管理、用例管理、报表统计于一体，完整覆盖测试项目管理的核心流程。

项目经理创建项目、组建团队、分配权限，相关职责人提交缺陷、处理缺陷，协助企业更好的进行测试项目的缺陷管理。

定制专属配置，精确管理测试项目

企业可根据自身原有的测试习惯，定制化专属测试项目管理工具。

1.自主配置项目角色
2.分配各角色权限
3.定制缺陷处理流程
4.自定义（缺陷、用例）属性

项目支持自主构建角色以及配置相应角色权限，支持按照企业自身习惯定制缺陷处理流程，支持自行添加缺陷或用例字段属性。

集成个性化产品，专业管理项目

Alltesting众测平台是一个面向全网用户的众包测试平台，能帮助很多没有测试团队的企业实现跨公司、跨地域、低成本的测试。Alltesting + TestCenter Enterprise，这样的两个平台是怎样相互协作？

1. 用户在众测平台发布项目，招募测试工程师进行测试；

2. 【缺陷管理】模块集成TestCenter Enterprise，测试者在TCE上按照专业规格提交缺陷；

3. 用户根据测试计划在TCE进行后续操作（添加开发、指派任务...）；

4. 处理后的缺陷状态返回众测，结项计费。


1.1 服务支持 - TestCenterEnterprise帮助文档

1.1 服务支持

我们通过在线QQ、微信、电话、电子邮件为您提供支持与服务，您也可访问我们的网站http://www.spasvo.com/寻求帮助；为保证服务质量，确保有效地解决用户的问题，保障用户的项目实施进度，技术支持仅向授权用户和授权试用用户提供。请您在联系泽众技术支持时，告知您的单位名称和服务代码。

技术支持
    电话：021-60725088-8007

传真：021-60725088-8017
    电子邮件：support@spasvo.com

QQ：1404189128

泽众微信公众号

产品服务

有关培训、产品购买及试用授权方法的问题，请与销售代表联系，或联系泽　众咨询热线。

电话：021-60725088-8006

传真：021-60725088-8017

电子邮件: sales@spasvo.com


2. 新手上路 - TestCenterEnterprise帮助文档

2. 新手上路

TestCenter Enterprise（以下简称“TCE”）是一个在线的轻量级测试项目管理平台，众测用户的账号密码可直接登录。在TCE，用户可以管理测试项目，管理项目中的人员、缺陷、用例等数据，具备导入导出功能，方便留存。

TCE以项目为单位，每个用户在不同的项目中都有自己的角色及权限，项目创建者默认为该项目的项目经理，具备所有权限。

TCE流程图：

项目管理

项目中心


2.1 名词解释 - TestCenterEnterprise帮助文档

2.1 名词解释

TestCenter Enterprise可管理两类项目，一类是 “众测项目”，另一类是 “TCE项目”。

“众测项目”为从Alltesting众测平台上创建的（对外众包测试）项目，同步显示在TCE。在众测加入项目的测试者默认项目角色为“众测测试者”，项目成员按默认的缺陷流程在TCE上提交及处理缺陷，缺陷情况同步回众测平台，最后在众测平台完成申诉、计费等功能。

“TCE项目”为用户在TCE上创建并管理的项目，多为企业或团队内部测试项目。项目角色、权限、缺陷流程等均按创建项目时选择的配置决定，且配置可定制化。TCE项目不涉及金钱交易。

以下为众测项目与TCE项目的对比：

属性 | 众测项目 | TCE项目
项目发布 | 在众测发布 项目数据同步至TCE | 在TCE发布 项目数据不同步至众测
项目配置 | 默认一套项目配置 不能自定义、不能修改 | 默认一套项目配置 可自定义角色权限 升级企业账号还能解锁更多定制化配置功能哦~（自主配置角色、缺陷流程定制、自定义模块属性）
项目成员 | 从众测加入项目的测试者默认角色为众测测试者 可自行添加开发及项目经理 无成员数量限制 | 可以自行添加项目成员，分配任意角色 可通过项目邀请码邀请成员 可从原有项目中批量添加成员 允许添加的项目成员数量受限于用户账号类型（免费版账号项目成员数不超过10人）
缺陷付费 | 因众测项目涉及到缺陷付费功能，所以默认的缺陷流程不允许修改。 按照流程处理后的缺陷，将缺陷状态同步至众测，针对“通过”和“驳回”的缺陷，在众测完成后续的计费及申诉功能。 | TC项目多为企业内部测试项目管理，不涉及金钱交易。
结项 | 在众测进行结项 | 在TC进行结项


2.2 快速入门 - TestCenterEnterprise帮助文档

2.2 快速入门


2.2.1 权限配置 - TestCenterEnterprise帮助文档

2.2.1 权限配置

路径： | 【角色管理】-【角色权限配置】
截图： |
步骤： | 1）点击“角色管理”； 2）选择想要修改的角色名称； 3）勾选或取消勾选修改角色的权限； 4）点击 “保存”，保存设置；


2.2.2 缺陷流程定制 - TestCenterEnterprise帮助文档

2.2.2 缺陷流程定制

“缺陷流程”顾名思义，就是bug的处理流程。虽然每个公司对处理流程中各状态/流程的叫法不同，但其主旨基本一致。

用户可以根据自身企业已有的缺陷处理工作流定制缺陷流程，定制流程中需要使用到的缺陷状态节点、选择流程使用的角色组、设计工作流（需要哪个角色将某一“起始状态”处理到另一“目标状态”的流程）。

路径： | 【缺陷流程定制】
截图： |
步骤： | 1）前提。若需要使用自己定义的角色及权限，请先至角色管理中定义好，方便定义流程时使用。若已经定义好或者直接使用默认角色，则进入下一步骤 2）定义状态。我们用缺陷状态的变化来代表进度（也就是流程），所以，在定义流程前需先定义缺陷状态。将所需的状态定义好之后，就可以真正的进行流程的定制啦。注意：必须设定一个初始状态。 3）流程定制。流程的组成：初始状态、目标状态处理角色、目标状态。一条流程就是缺陷由初始状态变为目标状态的过程，那么目标状态处理角色呢，就是指可以操作目标状态的用户角色。


2.2.3 新建/编辑项目 - TestCenterEnterprise帮助文档

2.2.3 新建/编辑项目

路径：

新建：【所有项目】-【新建项目】

编辑：【所有项目】-【编辑】

截图：

步骤：

1） 点击“新建项目”

2） 输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
项目名称 | 输入项目名称 | 1.不能为空 2.不能重复 3.最多20字符
开始时间 | 设置项目开始时间 | 1.不能晚于结束时间 2.日期不能早于新建项目日期
结束时间 | 设置项目结束时间 | 1.不能早于结束时间
缺陷流程 | 选择缺陷流程 | 1.有缺陷提交后则缺陷流程不可修改。 2.可联系管理员定制缺陷流程，此功能收费
项目模块 | 点击回车键添加项目模块 | 1.名称不能重复； 2.有缺陷提交后则缺陷流程不可修改。
项目描述 | 填写对项目的描述 | 1.必填； 2.少于500字符；

3） 新建：点击保存提示新增项目成功，并显示邀请码。

编辑：点击保存提示保存成功。


2.2.4 加入项目 - TestCenterEnterprise帮助文档

2.2.4 加入项目

路径： | 【所有项目】-【加入项目】
截图： |
步骤： | 1）点击“加入项目”； 2）输入“项目邀请码”； 3）点击 “确认”，加入项目；


2.2.5 缺陷管理 - TestCenterEnterprise帮助文档

2.2.5 缺陷管理


2.2.5.1 新建缺陷 - TestCenterEnterprise帮助文档

2.2.5.1 新建缺陷

路径：

新建：【进入项目】-【缺陷管理】-【新建缺陷】

截图：

步骤：

1）点击“新建缺陷”；

2）输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
缺陷名称 | 输入缺陷名称 | 1. 不能为空 2. 最多60字符
角色选择 | 选择角色 | 不能为空
处理人 | 选择处理人 | 不能为空
项目模块 | 选择项目模块 | 不能为空
缺陷类别 | 选择缺陷类别 | 不能为空
缺陷等级 | 选择缺陷等级 | 不能为空
出现频率 | 选择出现频率 | 不能为空
关联用例 | 选用关联用例 | 可不填
自定义属性 | 根据要求自定义属性 | 根据设置填写
缺陷描述 | 填写对缺陷的描述 | 1.不能为空； 2.少于500字符；
附件上传 | 选择文件，按住Ctrl可选多个文件 | 1.可不上传； 2.上传文件大小不大于20M

3）点击“提交”提示新增缺陷成功。


2.2.5.2 缺陷导入导出 - TestCenterEnterprise帮助文档

2.2.5.2 缺陷导入导出

路径： | 【进入项目】-【缺陷管理】-【更多操作】
截图： |
步骤： | 1） 配置缺陷导入导出模板，选择需要的属性列表； 2） 下载模板，填写各个属性的属性值； 3） 点击“更多操作—缺陷导入”，导入模板，就可以实现缺陷导入； 4） 点击“更多操作—缺陷导出”，就可以导出现有的缺陷；


2.2.5.3 查看筛选缺陷 - TestCenterEnterprise帮助文档

2.2.5.3 查看筛选缺陷

路径： | 【所有项目】-【加入项目】
截图： |
步骤： | 1) 点击“我提交的”查看我提交的缺陷； 2) 点击“待我处理的”查看待我处理的缺陷； 3) 点击“高级筛选”，根据缺陷状态、缺陷等级、创建时间、项目模块筛选；


2.2.5.4 缺陷查看与走缺陷流程 - TestCenterEnterprise帮助文档

2.2.5.4 缺陷查看与走缺陷流程

路径： | 【进入项目】-【缺陷管理】
截图： |
步骤： | 1) 点击缺陷名称，查看缺陷信息； 2）通过选择“缺陷状态”-“角色”-“处理人”进行缺陷流程；


2.2.6 用例管理 - TestCenterEnterprise帮助文档

2.2.6 用例管理


2.2.6.1 新建用例组 - TestCenterEnterprise帮助文档

2.2.6.1 新建用例组

路径： | 【进入项目】-【用例管理】
截图： |
步骤： | 1）点击上图中红色方框中的按钮，新增用例组


2.2.6.2 用例导入导出 - TestCenterEnterprise帮助文档

2.2.6.2 用例导入导出

路径： | 【进入项目】-【缺陷管理】-【更多操作】
截图： |
步骤： | 1）配置用例导入导出模板，选择需要的属性列表； 2）下载模板，填写各个属性的属性值； 3）点击“更多操作—用例导入”，导入模板，就可以实现用例导入； 4）点击“更多操作—用例导出”，就可以导出现有的用例；


2.2.6.3 新增、删除等用例操作 - TestCenterEnterprise帮助文档

2.2.6.3 新增、删除等用例操作

路径： | 【进入项目】-【用例管理】
截图： |
步骤： | 1） 点击“新增用例”，增添用例； 2） 点击“批量删除”，批量删除用例； 3） 点击“复制”、“粘贴”、“剪切”操作用例； 4） 点击用例名称，添加用例步骤；


2.2.6.4 用例执行 - TestCenterEnterprise帮助文档

2.2.6.4 用例执行

路径： | 【进入项目】-【用例管理】
截图： |
步骤： | 1） 点击“用例执行”，出现上图界面，填写实际结果； 2） 查看实际结果与预期结果是否一致； 3） 根据情况，选择执行状态“通过”、“未通过”、“阻塞”；


2.2.6.5 用例执行报表 - TestCenterEnterprise帮助文档

2.2.6.5 用例执行报表

路径： | 【进入项目】-【用例管理】-【查看用例执行报表】
截图： |
步骤： | 通过选择“基础统计”，“失败用例统计列表”，“用例执行统计”查看各个报表


2.2.7 团队管理 - TestCenterEnterprise帮助文档

2.2.7 团队管理

路径： | 【进入项目】-【团队管理】
截图： |
步骤： | 1） 点击“添加人员”，进行添加，可以通过搜索查找添加，也可以通过导入已有项目成员添加。 2） 点击“修改角色”，修改用户的角色； 3） 点击“删除”，删除不需要的用户；


2.2.8 文档管理 - TestCenterEnterprise帮助文档

2.2.8 文档管理

路径： | 【进入项目】-【文档管理】
截图： |
步骤： | 1） 点击“上传文档”，上传项目相关文档； 2） 点击“下载”，下载所需文档；


2.2.9 报表中心 - TestCenterEnterprise帮助文档

2.2.9 报表中心

路径： | 【进入项目】-【报表中心】
截图： |
步骤： | 通过选择“系列（缺陷状态）”，“子系列（空）”，“图形种类”查看各个报表


3. 功能介绍 - TestCenterEnterprise帮助文档

3. 功能介绍

TestCenter Enterprise（以下简称“TCE”）是一个在线的轻量级测试项目管理平台，众测用户的账号密码可直接登录。在TCE，用户可以管理测试项目，管理项目中的人员、缺陷、用例等数据，具备导入导出功能，方便留存。

TCE功能模块架构：


3.1 配置管理 - TestCenterEnterprise帮助文档

3.1 配置管理

用户在创建项目前，可在【配置管理】模块先进行定制化配置，包括配置项目角色组（及角色权限）、定制化缺陷处理流程、以及自定义模块属性。

（注：该模块的 增、删、改 功能的权限只对“企业版”用户开放，“普通版”用户只能进行相应查看。普通版用户可以付费将账号升级为企业账号）


3.1.1 角色管理 - TestCenterEnterprise帮助文档

3.1.1 角色管理

一、添加角色组

路径：

【角色管理】-【管理角色组】

描述：

点击进入角色管理，点击管理角色组，进行添加角色组

截图：

步骤：

1）点击角色管理

2）点击管理角色组

3）进行添加角色组

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
角色组名称 | 输入角色组名称 | 1.不能为空 2.不能重复
添加角色组 | 点击添加角色组，角色组添加成功 | 1. 添加成功，角色组在列表显示 2. 添加失败提示失败原因
编辑 | 点击编辑，对角色组名称进行修改编辑 | 1.不能为空 2.不能重复
删除 | 点击删除角色组 | 使用过的角色组不支持删除功能

4）点击确认或返回，返回角色管理界面

二、新增角色

路径：

【角色管理】-【新增角色】

描述：

选择非默认角色组，点击新增角色，进行新增角色

截图：

步骤：

1）选择非默认角色组

2）点击新增角色

3）进行新增角色

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
角色名称 | 输入角色名称 | 1.不能为空 2.已被引用的角色组不能新增角色

4）点击确认或返回，返回角色管理界面

三、角色权限配置

路径： | 【角色管理】-【角色权限配置】
描述： | 选择角色组下相应角色，勾选相应功能模块，点击保存，进行角色权限配置
截图： |
步骤： | 1）选择角色组下相应角色 2）勾选相应功能模块 3）点击保存，进行角色权限配置


3.1.2 缺陷流程定制 - TestCenterEnterprise帮助文档

3.1.2 缺陷流程定制

一、管理缺陷状态

路径：

【缺陷流程定制】-【管理缺陷状态】

描述：

点击进入缺陷流程定制，点击管理缺陷状态，进行缺陷状态管理

截图：

步骤：

1）点击进入缺陷流程定制

2）点击管理缺陷状态

3）进行缺陷状态管理

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
状态名称 | 输入状态名称 | 1.不能为空 2.最少两个字符
添加状态 | 点击添加状态 | 1.添加成功，状态在列表显示 2.添加失败提示失败原因
编辑 | 点击编辑，对状态进行修改编辑 | 1.不能为空 2.被引用的缺陷状态不能被修改
删除/批量删除 | 点击删除/批量删除 | 被引用的缺陷状态不能被删除

4）点击确认或返回，返回角色管理界面

二、添加流程

路径：

【缺陷流程定制】-【添加流程】

描述：

点击进入缺陷流程定制，点击添加流程，进行添加/编辑缺陷流程

截图：

步骤：

1）点击进入缺陷流程定制

2）点击添加流程进行添加/编辑缺陷流程

3）进行添加/编辑缺陷流程

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
流程名称 | 输入流程名称 | 1.不能为空 2.不能重复
选择角色组 | 下拉框选择角色组 | 不能为空
第一步处理人 | 下拉框选择第一步处理人 | 不能为空
添加 | 添加状态步骤 | 缺陷流程状态必须为闭环流程
默认开始 | 点击设置默认开始 | 默认开始只有一个
删除 | 删除状态步骤 |

4）点击确认流程创建成功，点击取消，取消添加流程，返回缺陷流程定制界面

5）流程创建成功之后，可以查看流程、修改流程和删除流程

（注：这里被项目引用过的流程不得修改和删除）


3.1.3 自定义模块属性 - TestCenterEnterprise帮助文档

3.1.3 自定义模块属性

新增属性

路径：

【自定义模块属性】-【新增属性】

描述：

点击进入自定义模块属性，点击新增属性，进行新增/编辑模块属性

截图：

步骤：

1）点击进入自定义模块属性

2）下拉框选择项目

3）点击新增属性，进行新增/编辑模块属性

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
属性名称 | 下拉框选择所属模块：缺陷、用例属性 | 不能为空
显示类型 | 下拉框选择显示类型 | 不能为空
是否显示 | 下拉框选择是否显示 | 不能为空
是否必填 | 下拉框选择是否必填 | 不能为空
默认值 | 设置默认值 | 非必填
选项值 | 设置选项值 |

4）点击确认添加成功，点击取消，取消添加，返回界面

5）属性新增成功以后可以进行编辑和删除


3.2 项目管理 - TestCenterEnterprise帮助文档

3.2 项目管理

【项目管理】用于用户管理项目，查看项目列表、新建项目、加入项目、结项项目等。项目列表用于显示当前登录用户已加入的项目和创建的项目，包括：众测项目和TCE项目。

TCE以项目为单位，每个用户在不同的项目中都有自己的角色及权限，项目创建者默认为该项目的项目经理，具备所有权限。

新建项目

路径：

1.用户从登录页登录TCE，进入项目管理列表，点击新建项目

2.已登录众测账号的用户，从众测入口进入TCE，自动进入项目管理列表，点击新建项目

3.用户从项目中心点击“切换项目”按钮，回到项目管理列表，点击新建项目

描述：

进入项目管理列表，点击新建项目，进行新建/编辑项目

截图：

步骤：

1）进入项目管理列表

2）点击新建项目，进行新建/编辑项目

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
项目名称 | 输入项目名称 | 不能为空
开始时间，结束时间 | 选择开始时间结束时间 | 结束时间不能早于开始时间
缺陷流程 | 下拉框选择缺陷流程 | 不能为空
项目模块 | 点击回车添加项目模块，且不能添加相同模块 | 默认有一个全部模块
项目描述 | 填写项目描述 | 必填

3）点击保存新建成功，点击返回，取消新建，返回项目管理列表界面

4）项目创建成功以后可以进行编辑

5）用户可以通过项目邀请码加入项目

6）项目结束以后，可以在这里进行结项项目


3.3 项目中心-缺陷管理 - TestCenterEnterprise帮助文档

3.3 项目中心-缺陷管理

用户登录TCE后从项目管理列表中“进入项目”后，默认定位该项目的【缺陷管理】模块。缺陷管理模块可查看该项目的缺陷列表，即显示当前项目下的所有缺陷，可筛选“我提交”和“待我处理”的缺陷。缺陷管理模块还可以完成提交缺陷、处理缺陷等操作，多方位管理项目的缺陷。


3.3.1 新建缺陷 - TestCenterEnterprise帮助文档

3.3.1 新建缺陷

路径：

从项目管理列表中“进入项目”后，【缺陷管理】-【新建缺陷】

描述：

进入项目管理列表“进入项目”后，点击新建缺陷，进行新建/编辑缺陷

截图：

步骤：

1）从项目管理列表“进入项目”

2）点击新建缺陷，进行新建/编辑缺陷

输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
缺陷名称 | 输入缺陷名称 | 不能为空
角色选择 | 选择处理人角色 | 必填
处理人 | 选择处理人 | 不能为空
项目模块 | 选择缺陷所属项目模块 | 默认全部模块
缺陷类别 | 选择缺陷类别 | 必填
缺陷等级 | 选择缺陷等级 | 必填
出现频率 | 选择缺陷频率 | 必填
关联用例 | 选择该缺陷关联的用例 | 非必填
自定义属性 | 自定义属性在配置管理个人中心添加以后此处才有显示 |
缺陷描述 | 添加缺陷描述 | 必填
附件上传 | 选择文件上传 |

3）选择是否连续添加

4）点击提交新建缺陷成功，点击返回，取消新建，返回缺陷管理列表界面

5）项目创建成功以后可以进行编辑

6）用户可以通过项目邀请码加入项目

7）项目结束以后，可以在这里进行结项项目


3.3.2 导入导出缺陷 - TestCenterEnterprise帮助文档

3.3.2 导入导出缺陷

配置导入导出模板，然后根据模板，完成批量导入缺陷、及批量导出缺陷的功能。

路径：

【缺陷管理】-【更多操作】-【导入导出配置】-【缺陷导入】-【缺陷导出】

描述：

进入缺陷管理，点击更多操作，进行导入导出配置，然后根据配置模板，导入导出缺陷

截图：

步骤：

1）在缺陷管理模块，点击更多操作

2）进行导入导出配置

配置下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
附件导出 | 选择附件导出或者不导出 |
属性列表 | 双击选择属性 |
保存 | 保存已选属性 |
下载模版 | 下载带有已选属性的模版 |
上移下移 | 已选属性可以上下移动位置 |
移除 | 移除已选属性 | 必须字段不可移除

3）模版配置完成后，根据模版配置缺陷导入文档：

4）点击缺陷导入，选择配置好的缺陷导入文档导入

5）点击缺陷导出，导出全部缺陷

6）点击提交新建缺陷成功，点击返回，取消新建，返回缺陷管理列表界面


3.3.3 处理缺陷/缺陷详情 - TestCenterEnterprise帮助文档

3.3.3 处理缺陷/缺陷详情

用户在缺陷列表点击缺陷名称，右侧切出缺陷详情页。该页可用于处理缺陷、追加描述、查看缺陷详情及历史操作等信息。

路径：

【缺陷管理】- 点击缺陷名称

描述：

进入缺陷管理，在缺陷列表点击缺陷名称，进入缺陷详情，进行缺陷处理

截图：

步骤：

1）在缺陷列表点击缺陷名称

2）进入缺陷详情，进行缺陷处理

配置下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
缺陷状态 | 选择缺陷状态 |
角色 | 选择下一处理人角色 |
处理人 | 选择处理人 |
缺陷描述 | 追加缺陷描述 |

3）点击提交，缺陷提交成功。


3.3.4 修改缺陷处理人 - TestCenterEnterprise帮助文档

3.3.4 修改缺陷处理人

项目经理，可以将缺陷处理任务分配给他人。缺陷处理人，也可以通过“修改处理人”功能将缺陷移交给与当前处理人同角色的其他成员处理。

路径：

【缺陷管理】- 修改处理人

描述：

进入缺陷管理，选择要修改的缺陷，点击修改处理人，进行缺陷移交

截图：

步骤：

1）选择要修改的缺陷

2）点击修改处理人，进行选择处理人

配置下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
角色 | 选择下一处理人角色 |
用户 | 选择处理人用户 |

3）点击确认，修改成功，点击取消，取消修改。


3.3.5 缺陷关联用例 - TestCenterEnterprise帮助文档

3.3.5 缺陷关联用例

勾选缺陷，点击关联用例按钮，可新增或修改该缺陷的关联用例情况。关联用例成功后，会显示在缺陷详情中。

路径： | 【缺陷管理】- 关联用例
描述： | 勾选缺陷，点击关联用例按钮，进行新增或修改用例关联
截图： |
步骤： | 1）勾选缺陷 2）点击关联用例按钮，选择要关联的用例 3）勾选要关联的用例 4）点击确认，关联成功，点击取消，取消关联


3.3.6 高级筛选 - TestCenterEnterprise帮助文档

3.3.6 高级筛选

点击【高级筛选】按钮，弹出高级筛选下拉内容。可直接勾选筛选条件，点击【确定】，进行筛选。

路径： | 【缺陷管理】- 高级筛选
描述： | 在缺陷管理模块，点击高级筛选按钮，弹出下拉内容
截图： |
步骤： | 1）点击高级筛选 2）根据勾选缺陷状态筛选 3）根据缺陷等级筛选 4）根据项目模块筛选 5）根据创建时间筛选 6）点击确认，筛选出条件缺陷，点击重置，重置筛选条件 7）点击收起高级筛选，收起下拉内容。


3.4 项目中心-用例管理 - TestCenterEnterprise帮助文档

3.4 项目中心-用例管理


3.4.1 新增用例 - TestCenterEnterprise帮助文档

3.4.1 新增用例

一、新增用例组

路径： | 【进入项目】-【用例管理】
截图： |
步骤： | 1）点击上图中红色方框中的按钮，新增用例组

二、新增用例

路径：

【进入项目】-【用例管理】-【新增用例】

截图：

步骤：

1）点击新增用例按钮

2）输入如下栏位：

栏位名称 | 描述 | 特殊要求
用例名称 | 输入用例名称 | 1. 必填 2. 不大于50字符
前提条件 | 输入前提条件 | 非必填，不大于300字符
用例描述 | 输入用例描述 | 非必填，不大于300字符

3）点击确定，新增用例成功

三、用例详情

路径： | 【进入项目】-【用例管理】
截图： |
步骤： | 1）点击用例名称进入用例详情 2）点击添加步骤进行用例步骤添加 3）点击提交，提示保存成功


3.4.2 导出用例 - TestCenterEnterprise帮助文档

3.4.2 导出用例

路径： | 【进入项目】-【用例管理】-【更多操作】
截图： |
步骤： | 1）点击导出用例 2）勾选需要导出的用例 3）点击确认，导出用例成功
注意： | 更多操作中点击导入导出配置，选择带附件导出可以导出用例附件以及用例


3.4.3 导入用例 - TestCenterEnterprise帮助文档

3.4.3 导入用例

路径： | 【进入项目】-【用例管理】-【更多操作】
截图： |
步骤： | 1）选择需要导出的属性，点击保存模板 2）下载相应模板并按照属性填写需要导入的数据 3）点击导入用例，提示用例导入成功
注意： | 因为导入涉及到数据库字段，需要使用由模板配置之后下载后的模板进行导入


3.4.4 用例统计 - TestCenterEnterprise帮助文档

3.4.4 用例统计

路径： | 【进入项目】-【用例管理】-【更多操作】
截图： |
步骤： | 可以通过用例创建人或者用例创建时间来查询相应的用例，统计出用例个数


3.4.5 用例执行 - TestCenterEnterprise帮助文档

3.4.5 用例执行

路径： | 【进入项目】-【用例管理】
截图： |
步骤： | 1）点击“用例执行”，出现上图界面，填写实际结果； 2）查看实际结果与预期结果是否一致； 3）根据情况，选择执行状态“通过”、“未通过”、“阻塞”；
注意： | 选择未通过时可以点击提交缺陷，自动将缺陷与用例进行绑定；通过缺陷跟踪相应的用例执行情况


3.4.6 执行报表 - TestCenterEnterprise帮助文档

3.4.6 执行报表

路径： | 【进入项目】-【用例管理】-【查看用例执行报表】
截图： |
步骤： | 通过选择“基础统计”，“失败用例统计列表”，“用例执行统计”查看各个报表


3.5 团队管理 - TestCenterEnterprise帮助文档

3.5 团队管理


3.5.1 添加人员 - TestCenterEnterprise帮助文档

3.5.1 添加人员

路径： | 【进入项目】-【团队管理】
截图： |
 | 点击“添加人员”，出现下图：
截图： |
添加人员方式： | 1）点击“项目邀请码”，查看项目邀请码，通过项目邀请码，添加人员； 2）通过搜索用户添加人员，同时可分配角色； 3）通过“导入已有项目成员”添加人员；


3.5.2 批量删除与删除 - TestCenterEnterprise帮助文档

3.5.2 批量删除与删除

路径： | 【进入项目】-【团队管理】
截图： |
步骤： | 1） 点击“删除”，删除对应用户； 2） 勾选多个用户，点击“批量删除”，删除多个用户；


3.5.3 修改角色 - TestCenterEnterprise帮助文档

3.5.3 修改角色

路径： | 【进入项目】-【团队管理】
截图： |
步骤： | 1）点击“修改角色”，出现上图提示框； 2）通过勾选角色，修改用户角色；


3.6 文档管理 - TestCenterEnterprise帮助文档

3.6 文档管理


3.6.1 上传文档 - TestCenterEnterprise帮助文档

3.6.1 上传文档

路径： | 【进入项目】-【文档管理】
截图： |
步骤： | 点击“上传文档”，上传项目相关文档。


3.6.2 下载、删除文档 - TestCenterEnterprise帮助文档

3.6.2 下载、删除文档

路径： | 【进入项目】-【文档管理】
截图： |
步骤： | 点击“下载”，下载所需相关文档；点击“删除”，删除不需要的文档。


3.7 报表中心 - TestCenterEnterprise帮助文档

3.7 报表中心


3.7.1 基础统计 - TestCenterEnterprise帮助文档

3.7.1 基础统计

用于统计不同状态、不同模块、不同等级的缺陷数量以及两两间的数量对比等。

点击【报表中心】，默认显示“缺陷状态-缺陷数量”直方图。（即系列选中缺陷状态，子系列未选择，图形种类选中直方图，生成的图表。）

图表条件说明

条件 | 限制 | 说明
系列 | 必选 | 选项：1 缺陷状态、2 缺陷等级、3 项目模块
子系列 | 可不选 | 选项：1 缺陷状态、2 缺陷等级、3 项目模块 不能与系列相同
图形种类 | 必选 | 选项：1 直方图、2 饼图、3 表格

1）直方图

Ø 纵轴默认为“缺陷数量”；

Ø 选择的“系列”为横轴；

Ø 选择的“子系列”为横轴上对比的类型。

（“子系列”可不选，不选则为系列-缺陷数量图，选择则为系列-子系列图。）

2）饼图

Ø 所选“系列”各属性在数量上所占的比例。

（不管“子系列”是否选择，均显示“系列”各属性数量占比。）

3）表格

Ø 一类：选择的“系列”类型对应的缺陷数量表格。

Ø 二类：选择的“系列”与“子系列”对比的缺陷数量表格。


3.7.2 每日变化曲线 - TestCenterEnterprise帮助文档

3.7.2 每日变化曲线

用于统计每日缺陷状态的变化情况。

默认显示近两周时间内每日各缺陷状态下的缺陷数量，呈现其变化曲线。（即纵轴为缺陷数量，横轴为近两周日期，点为各状态的缺陷）

图表条件说明

时间范围：必选项、默认显示近两周日期、可精确至小时图。


3.7.3 报表打印、另存为 - TestCenterEnterprise帮助文档

3.7.3 报表打印、另存为

通过上图红色方框中的操作，可以对报表进行“打印”“保存为PNG、JPG、PDF格式文件”


4. 特点介绍 - TestCenterEnterprise帮助文档

4. 特点介绍


4.1 缺陷处理流程定制 - TestCenterEnterprise帮助文档

4.1 缺陷处理流程定制

缺陷流程定制中的缺陷处理流程，可以根据用户的实际需求进行定制，定制后的处理流程将更加适合项目管理者了解项目进度和把控缺陷的处理效率。

注：缺陷流程定制需要在项目中没有提交缺陷引用过流程才可以进行配置，如果已经引用了流程提交缺陷，是无法进行修改配置的。


4.2 缺陷和用例的导入导出 - TestCenterEnterprise帮助文档

4.2 缺陷和用例的导入导出

TCE项目中的缺陷和用例可以通过新建一个一个的添加，但是，当遇到大量缺陷和用例时，单个的新建费时费力。此时，TCE提供缺陷和用例的导入导出功能，只需在导入前，进行导入导出模板的配置，就可以实现缺陷和用例的批量导入，从而减少大量的时间。


4.3 统计报表 - TestCenterEnterprise帮助文档

4.3 统计报表

在TCE中执行用例、新建缺陷、处理缺陷等都会自动产生各种统计图表，用户可直接通过这些图表查看缺陷和用例的信息，同时还可以生成不同形式的图标，例如：直方图、饼图、表格。


5. 常见问题 - TestCenterEnterprise帮助文档

5. 常见问题


5.1 注册问题 - TestCenterEnterprise帮助文档

5.1 注册问题

如何注册TestCenter Enterprise账号？

答：TestCenter Enterprise账号与Alltesting众测账号通用，TCE无独立注册页面，故必须前往众测注册页进行注册，注册时选择角色只对众测发布项目有影响，注册后账号可用于登录上海泽众TC、PR等所有工具平台。


5.2 费用问题 - TestCenterEnterprise帮助文档

5.2 费用问题

在TCE提交缺陷的众测项目还能获得缺陷费用吗？

答：可以。在TCE处理后的缺陷状态会同步回众测，在众测，根据缺陷状态反馈计费结果。“通过”和“申诉成功”状态的缺陷依然可在众测上获得缺陷费用。


5.3 账号问题 - TestCenterEnterprise帮助文档

5.3 账号问题

普通版和企业版账号有何区别？

答：普通用户初始皆为普通版账号，可在TCE免费创建并管理5个项目成员数不超过10的项目，按照TCE默认的项目配置、缺陷流程进行测试项目管理。而升级为企业版账号后，则能创建并管理更多项目，且均可进行自定义属性及流程、角色等配置。


5.4 项目问题 - TestCenterEnterprise帮助文档

5.4 项目问题

怎样定制缺陷流程？

答：升级为企业版账号可定制自己的专属缺陷处理流程，有需求的普通用户也可以联系管理员（运维QQ：3246685792）为您量身定制缺陷流程。编辑缺陷流程功能操作可参见帮助中心缺陷流程定制。